Some API features are experiencing issues

Incident Report for TwelveLabs

Resolved

All affected API features have recovered.
Posted Jul 15, 2026 - 02:00 PDT

Update

Embed by video is currently experiencing issues. We are investigating.
Posted Jul 15, 2026 - 01:57 PDT

Investigating

Embed by video is currently experiencing issues. We are investigating.
Posted Jul 15, 2026 - 01:54 PDT
This incident affected: API (Embed API - Marengo3.0 - Video).