Some API features are experiencing issues

Incident Report for TwelveLabs

Resolved

All affected API features have recovered.
Posted Sep 03, 2026 - 15:25 PDT

Update

Analyze SME with Pegasus 1.5 is currently experiencing issues. We are investigating.
Posted Sep 03, 2026 - 15:11 PDT

Investigating

The following API features are currently experiencing issues:

- Analyze SME with Pegasus 1.5
- Analyze general with Pegasus 1.5

We are investigating.
Posted Sep 03, 2026 - 15:11 PDT

Identified

We are experiencing elevated error rates across multiple Marengo and Pegasus endpoints due to an ongoing AWS incident affecting AWS Security Token Service and authentication services. Our engineering team is actively monitoring the incident and evaluating mitigation options. No workaround is currently available.
We will provide another update as more information becomes available.
Posted Sep 03, 2026 - 15:09 PDT

Update

We are continuing to investigate this issue.
Posted Sep 03, 2026 - 15:08 PDT

Update

Multiple endpoints including Analyze and Embed are currently experiencing issues. We are investigating.
Posted Sep 03, 2026 - 15:04 PDT

Investigating

Analyze SME with Pegasus 1.5 is currently experiencing issues. We are investigating.
Posted Sep 03, 2026 - 14:32 PDT
This incident affected: API (Analyze API - Pegasus1.5 (Segment Based Metadata)).