On June 5, 2026 from 1:38 PM to 2:43 PM PDT (~65 minutes), the Analyze API (including video summarize) experienced elevated error rates. Customers attempting to run analyze or summarize tasks received HTTP 5xx errors or delayed task completion. The issue was caused by elevated latency in a backend caching layer, which prevented our task-orchestration system from scaling to meet demand. Task throughput collapsed and the queue accumulated, leading to user-facing failures. Our team identified the latency source, restored normal scaling behavior, and drained the backlog. No customer data was lost; affected tasks can be retried. We have begun work to prevent recurrence, including additional alerting on the caching layer and improvements to the scaling fallback path.
Posted Jun 05, 2026 - 14:43 PDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2026 - 13:45 PDT
This incident affected: API (Analyze API - Pegasus1.5 (General), Analyze API - Pegasus1.5 (Segment Based Metadata), Analyze API - Pegasus1.2).