Some API features are experiencing issues

Incident Report for TwelveLabs

Resolved

All affected API features have recovered.
Posted Jul 15, 2026 - 03:35 PDT

Update

The following API features are currently experiencing issues:

- Embed by video
- Index creation and video upload

We are investigating.
Posted Jul 15, 2026 - 03:18 PDT

Update

The following API features are currently experiencing issues:

- Embed by video
- Index creation and video upload

We are investigating.
Posted Jul 15, 2026 - 03:15 PDT

Update

Index creation and video upload is currently experiencing issues. We are investigating.
Posted Jul 15, 2026 - 03:09 PDT

Update

Embed by video is currently experiencing issues. We are investigating.
Posted Jul 15, 2026 - 03:03 PDT

Update

The following API features are currently experiencing issues:

- Embed by video
- Index creation and video upload

We are investigating.
Posted Jul 15, 2026 - 02:57 PDT

Investigating

Embed by video is currently experiencing issues. We are investigating.
Posted Jul 15, 2026 - 02:54 PDT
This incident affected: API (Video Indexing Task API - Marengo3.0, Embed API - Marengo3.0 - Video).