Some API features are experiencing issues

Incident Report for TwelveLabs

Resolved

All affected API features have recovered.
Posted Sep 09, 2026 - 00:41 PDT

Update

The following API features are currently experiencing issues:

- Index creation and video upload
- Marengo 3.0 Embed API - Async

We are investigating.
Posted Sep 08, 2026 - 22:00 PDT

Investigating

The following API features are currently experiencing issues:

- Index creation and video upload
- Marengo 3.0 Embed API - Async

We are investigating.
Posted Sep 08, 2026 - 21:57 PDT
This incident affected: API (Video Indexing Task API - Marengo3.0, Embed API - Marengo3.0 - Async).