Some API features are experiencing issues

Incident Report for TwelveLabs

Resolved

All affected API features have recovered.
Posted Jul 29, 2026 - 06:22 PDT

Investigating

Search by text is currently experiencing issues. We are investigating.
Posted Jul 29, 2026 - 06:20 PDT
This incident affected: API (Search by Text API - Marengo3.0).